HyPhy message board
http://www.hyphy.org/cgi-bin/hyphy_forums/YaBB.pl
HYPHY Package >> HyPhy bugs >> Installation problem
http://www.hyphy.org/cgi-bin/hyphy_forums/YaBB.pl?num=1387474307

Message started by RTuteja on Dec 19th, 2013 at 9:31am

Title: Installation problem
Post by RTuteja on Dec 19th, 2013 at 9:31am
Hi Sergei,

I am getting following warning while installing hyphy:

-- Configuring done
WARNING: Target "hyphy_mp" has EXCLUDE_FROM_ALL set and will not be built by default but an install rule has been provided for it.  CMake does not define behavior for this case.
WARNING: Target "HYPHYMP" has EXCLUDE_FROM_ALL set and will not be built by default but an install rule has been provided for it.  CMake does not define behavior for this case.
WARNING: Target "HYPHYSP" has EXCLUDE_FROM_ALL set and will not be built by default but an install rule has been provided for it.  CMake does not define behavior for this case.
WARNING: Target "HYPHYMPI" has EXCLUDE_FROM_ALL set and will not be built by default but an install rule has been provided for it.  CMake does not define behavior for this case.
WARNING: Target "HYPHYDEBUG" has EXCLUDE_FROM_ALL set and will not be built by default but an install rule has been provided for it.  CMake does not define behavior for this case.


and when I try to run make MPI then I get the following errors. Can you please help!

/ichec/home/packages/intel-cluster-studio/2013-sp1/impi/4.1.1.036/intel64/include/mpicxx.h:95:2: error: #error "SEEK_SET is #defined but must not be for the C++ binding of MPI. Include mpi.h before stdio.h"
/ichec/home/packages/intel-cluster-studio/2013-sp1/impi/4.1.1.036/intel64/include/mpicxx.h:99:2: error: #error "SEEK_CUR is #defined but must not be for the C++ binding of MPI. Include mpi.h before stdio.h"
/ichec/home/packages/intel-cluster-studio/2013-sp1/impi/4.1.1.036/intel64/include/mpicxx.h:104:2: error: #error "SEEK_END is #defined but must not be for the C++ binding of MPI. Include mpi.h before stdio.h"
make[3]: *** [CMakeFiles/HYPHYMPI.dir/src/core/batchlan.cpp.o] Error 1
make[2]: *** [CMakeFiles/HYPHYMPI.dir/all] Error 2
make[1]: *** [CMakeFiles/HYPHYMPI.dir/rule] Error 2
make: *** [HYPHYMPI] Error 2

Thanks,
Reetu


Title: Re: Installation problem
Post by RTuteja on Dec 20th, 2013 at 3:50am
Hi Sergei,

I sorted out this problem.

Thanks,
Reetu

Title: Re: Installation problem
Post by Steven on Dec 20th, 2013 at 9:48am
Hi Reetu,

Can you mention what you did to fix the problem?

Thanks,
Steven

HyPhy message board » Powered by YaBB 2.5.2!
YaBB Forum Software © 2000-2021. All Rights Reserved.