Welcome, Guest. Please Login
YaBB - Yet another Bulletin Board
 
  HomeHelpSearchLogin  
 
Error in compiling HYPHY 2.2.0 "FindQT4.cmake" (Read 6282 times)
jackson
YaBB Newbies
*
Offline


I love YaBB 1G - SP1!

Posts: 30
São Paulo, Brazil
Gender: male
Error in compiling HYPHY 2.2.0 "FindQT4.cmake"
Jul 10th, 2013 at 4:33am
 
Hello,
I'm trying to compile the HYPHY 2.2.0 on ubuntu 13.04 x64 but this error "FindQT4.cmake" appears, even though the computer and QT4 instlado PATH indicating his path:

jackson@jackson-desktop:~/Downloads/hyphy-master$ printenv PATH
/usr/local/Trolltech/Qt-4.8.5/bin:/usr/lib/lightdm/lightdm:/usr/local/sbin:/usr/
local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games:/usr/local/games:/usr/local/c
uda-5.0/bin:/usr/local/Trolltech/Qt-4.8.5/bin:/usr/local/cuda-5.0/bin


The following compilation:

jackson@jackson-desktop:~/Downloads/hyphy-master$ cmake .
-- The C compiler identification is GNU 4.4.7
-- The CXX compiler identification is GNU 4.7.3
-- Check for working C compiler: /usr/bin/cc
-- Check for working C compiler: /usr/bin/cc -- works
-- Detecting C compiler ABI info
-- Detecting C compiler ABI info - done
-- Check for working CXX compiler: /usr/bin/c++
-- Check for working CXX compiler: /usr/bin/c++ -- works
-- Detecting CXX compiler ABI info
-- Detecting CXX compiler ABI info - done
-- Performing Test HAVE_AVX_EXTENSIONS
-- Performing Test HAVE_AVX_EXTENSIONS - Success
-- Try OpenMP C flag = [-fopenmp]
-- Performing Test OpenMP_FLAG_DETECTED
-- Performing Test OpenMP_FLAG_DETECTED - Success
-- Try OpenMP CXX flag = [-fopenmp]
-- Performing Test OpenMP_FLAG_DETECTED
-- Performing Test OpenMP_FLAG_DETECTED - Success
-- Found OpenMP: -fopenmp 
-- Found PythonInterp: /usr/bin/python (found version "2.7.4")
-- Looking for include file pthread.h
-- Looking for include file pthread.h - not found
-- Could NOT find Threads (missing:  Threads_FOUND)
-- Found OpenCL: /usr/lib/libOpenCL.so 
-- Found MPI_C: /usr/lib/libmpich.so;/usr/lib/libopa.so;/usr/lib/libmpl.so;/usr/lib/x86_64-linux
-gnu/librt.so;/usr/lib/libcr.so;/usr/lib/x86_64-linux-gnu/libpthread.so 
-- Found MPI_CXX: /usr/lib/libmpichcxx.so;/usr/lib/libmpich.so;/usr/lib/libopa.so;/usr/lib/libmpl.
so;/usr/lib/x86_64-linux-gnu/librt.so;/usr/lib/libcr.so;/usr/lib/x86_64-linux-gn
u/libpthread.so 
CMake Warning at CMakeLists.txt:477 (find_package):
  By not providing "FindQT4.cmake" in CMAKE_MODULE_PATH this project has
  asked CMake to find a package configuration file provided by "QT4", but
  CMake did not find one.

  Could not find a package configuration file provided by "QT4" with any of
  the following names:

    QT4Config.cmake
    qt4-config.cmake

  Add the installation prefix of "QT4" to CMAKE_PREFIX_PATH or set "QT4_DIR"
  to a directory containing one of the above files.  If "QT4" provides a
  separate development package or SDK, be sure it has been installed.


-- Configuring done
WARNING: Target "hyphy_mp" has EXCLUDE_FROM_ALL set and will not be built by default but an install rule has been provided for it.  CMake does not define behavior for this case.
WARNING: Target "HYPHYMP" has EXCLUDE_FROM_ALL set and will not be built by default but an install rule has been provided for it.  CMake does not define behavior for this case.
WARNING: Target "HYPHYOCL" has EXCLUDE_FROM_ALL set and will not be built by default but an install rule has been provided for it.  CMake does not define behavior for this case.
WARNING: Target "HYPHYMPI" has EXCLUDE_FROM_ALL set and will not be built by default but an install rule has been provided for it.  CMake does not define behavior for this case.
WARNING: Target "HYPHYDEBUG" has EXCLUDE_FROM_ALL set and will not be built by default but an install rule has been provided for it.  CMake does not define behavior for this case.
-- Generating done

Any tips of what to do?

Best regards,

Jackson Lima
Back to top
 
 
IP Logged
 
Steven
Global Moderator
*****
Offline


Datamonkey Curious

Posts: 21
Gender: male
Re: Error in compiling HYPHY 2.2.0 "FindQT4.cmake"
Reply #1 - Jul 10th, 2013 at 1:01pm
 
Hi there,
This error resulted because of Line 478 in CMakeLists.txt.

CMake was searching for the file "FindQT4.cmake" when the filename was really "FindQt4.cmake".

I have since resolved this issue, and it is in the current master branch on github.

Thanks,
Steven
Back to top
 
 
IP Logged
 
jackson
YaBB Newbies
*
Offline


I love YaBB 1G - SP1!

Posts: 30
São Paulo, Brazil
Gender: male
Re: Error in compiling HYPHY 2.2.0 "FindQT4.cmake"
Reply #2 - Jul 10th, 2013 at 6:08pm
 
Thanks Steven!

Now continuing the compilation, when I run the make HYPHYMP command or other,  this error appears related to SQLite:

[ 92%] Building CXX object CMakeFiles/HYPHYMPI.dir/src/new/bgm.cpp.o
[100%] Building C object CMakeFiles/HYPHYMPI.dir/contrib/SQLite-3.7.11/sqlite3.c.o
/home/jackson/Downloads/hyphy-master/contrib/SQLite-3.7.11/sqlite3.c:1: error: bad value (corei7-avx) for -march= switch
/home/jackson/Downloads/hyphy-master/contrib/SQLite-3.7.11/sqlite3.c:1: error: bad value (corei7-avx) for -mtune= switch
make[3]: ** [CMakeFiles/HYPHYMPI.dir/contrib/SQLite-3.7.11/sqlite3.c.o] Erro 1
make[2]: ** [CMakeFiles/HYPHYMPI.dir/all] Erro 2
make[1]: ** [CMakeFiles/HYPHYMPI.dir/rule] Erro 2
make: ** [HYPHYMPI] Erro 2

Thus the executable file is not created.


It would also have any tips?

Best regards,

Jackson Lima

Ps: Does the error also occurs because of the case? Here is the command to run SQLite on my pc:

jackson @ jackson-desktop: ~ / Downloads / hyphy-master $ sqlite3
SQLite version 3.7.15.2 2013-01-09 11:53:05
Enter. "Help" for instructions
Back to top
 
 
IP Logged
 
Steven
Global Moderator
*****
Offline


Datamonkey Curious

Posts: 21
Gender: male
Re: Error in compiling HYPHY 2.2.0 "FindQT4.cmake"
Reply #3 - Jul 10th, 2013 at 6:42pm
 
Hi Jackson,

Please make sure you are using gcc version 4.6 or above. Your current compiler does not support "corei7-avx".

Thanks,
Steven
Back to top
 
 
IP Logged